iNet_forum_header_100112
Canon USA
Reply
New Contributor
Islander
Posts: 1
Registered: ‎09-01-2013

Getting U052 (type of printhead incorrect) on my Pixma MP610 printer).

I'm getting a U052 error message on my Pixma MP610 printer.  It reads "The type of printhead is incorrect. Install the correct printhead."  I replaced an ink cartridge that was running low, but still get that message.  I've had the printer for some time and never got that kind of message before.

Please use plain text.
Product Expert
Ramona
Posts: 503
Registered: ‎10-17-2012

Re: Getting U052 (type of printhead incorrect) on my Pixma MP610 printer).

Hi Islander,

 

To try and resolve the U052 error, please remove and then reseat all of the ink tanks and print head in the unit.  Next, please turn off the printer, unplug the power cord from the back and leave it out for at least 10 minutes, then plug it back in and turn it back on. 

 

If the U052 error persists after following the steps above, the printer will require servicing.  Please click on the Contact Us link below to obtain your servicing options if needed.

 

This didn't answer your question or issue? Find more help at Contact Us .

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Please use plain text.
New Contributor
TanjaStar
Posts: 1
Registered: ‎02-05-2014

Re: Getting U052 (type of printhead incorrect) on my Pixma MP610 printer).

hi

I remember having simillar problem before and i've heared this comes from cold, which is just possible for me.

 i  remember pressing and holding few buttons (not those to enter service mode) and then it worked fine again.

Can you please remind me which those buttons were.

Please use plain text.
New Contributor
simonf
Posts: 1
Registered: ‎02-24-2014

Re: Getting U052 (type of printhead incorrect) on my Pixma MP610 printer).

 

Hi, I had the same error that started after changing an ink cartridge. The new cartridge was from a different supplier than I normally use.

 

I found that by installing cartridges from my original supplier, then restarting the printer, the error went away. Didn't have to do any of the cleaning print heads, etc.

Please use plain text.
New Contributor
Mrs_LittleHoop
Posts: 1
Registered: ‎03-04-2014

Re: Getting U052 (type of printhead incorrect) on my Pixma MP610 printer).

I also have the U052 (type of printhead incorrect on my Pixma MP610 printer.  It was working fine one day and the next it quit working.  At that time no error messages yet when I went to print someting a blank page would come out.  I let it sit a few days due to the fact that I was busy and then I turned it back on and all of a sudden I recieved the U052 message.  I am so furstrated :smileysad:  Obviously from the other post on here and other boards replacing the print head is not a solution.  It also seems to happen with many other printers.  Boo to canon.

Please use plain text.
New Contributor
mkrolljr
Posts: 1
Registered: ‎04-02-2014

Re: Getting U052 (type of printhead incorrect) on my Pixma MP610 printer).

I just received this message on my MP610. I printed a page of 2, then the printer went dead..would not power up. let it sit overnight, and it powered back on, but now I get the U052 error message. Tried reseting the printhead, etc, but nothing works.

 

I have never used anything but genuine Canon cartridges, but this wasnt much help.

 

Any suggestions. If I need service, what are my options. I have several cartridges here, as I do a lot of printing. There are no printers available that use the same cartridges.

 

thanks..marty

Please use plain text.
New Contributor
pdwyer37
Posts: 1
Registered: ‎08-29-2014

Re: Getting U052 (type of printhead incorrect) on my Pixma MP610 printer).

Does not work.

Please use plain text.
New Contributor
EOSluvr
Posts: 1
Registered: ‎08-30-2014

Re: Getting U052 (type of printhead incorrect) on my Pixma MP610 printer).

Along with many, I have the same recurring problem with my MP610.  One noteworthy difference (Canon support) is that it works fine on my desktop and laptop (Win7) and only creates the error with my wife's laptop (HP with Win7).  I've reinstalled the driver several times on her laptop and it works a few times but then comesback.  I have to reset the MP610 by turning off before I can use it with my pc's.  Definitely a frustrating issue for an otherwise nice unit.

Please use plain text.