iNet_forum_header_100112
Canon USA
Reply
New Contributor
tlambert
Posts: 1
Registered: ‎12-09-2013

Cannot communicate with the printer.

I just bought a PIXMA MG222O a few months back and i have recently updated my computer to window 8.1 and now my printer is saying Cannot communicate with the printer.
Turn Enable bi-directional support on in the printer's Properties dialog box. i did not find that anywhere in the printers properties dialog box. I researched and found that other people were having the same problem so i tried down loading what they did and mine is still not working. What can i do to fix this?

Please use plain text.
New Contributor
SP_prt
Posts: 2
Registered: ‎12-31-2013

Re: Cannot communicate with the printer.

I, too, am having this same problem with my Canon MX710 printer, which I am using in wireless mode.  The message I get is:

 

           Cannot communicate with the printer.
           Turn Enable bi-directional support on in the printer's Properties dialog box.

 

Some of the time my document will then go ahead and print.  Other times I get a message that my printer is off-line.  Everything worked fine until I updated to Windows 8.1 a couple of months ago.  Does anyone know how to solve this problem? 

Please use plain text.
Product Expert
Ramona
Posts: 634
Registered: ‎10-17-2012

Re: Cannot communicate with the printer.

hi tlambert,

 

Please follow these steps to enable bi-directional support:

 

1.  On your keyboard, hold the Windows key and press " X ".

2.  Click CONTROL PANEL.

3.  Select DEVICES AND PRINTERS.  The Devices and printers window opens.

4.  Click your right mouse button on the listing for your printer, and then select PRINTER PROPERTIES from the menu that appears.

5.  In the printer's PROPERTIES window, select PORTS, then check the box for 'Enable bidirectional support'.

6.  Press the OK button to save the changes.

 

Hope this helps! 

 

If you still experience difficulty, please feel free to Contact Us for further assistance.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Please use plain text.
New Contributor
SP_prt
Posts: 2
Registered: ‎12-31-2013

Re: Cannot communicate with the printer.

To be allowed to enter the change per the instructions, I found that I first had to click on the "Change Properties" button on the GENERAL tab.  Without this step, everything was faded out on the PORTS tab.  After clicking the "Change Properties" button, I was then able to check the box for "Enable bidirectional support" on the PORTS tab.  Now printing works perfectly!  After several months of encountering the communication problem, it is great to have it working properly again.  Thank you very much, Ramona!

Please use plain text.
New Contributor
raydio
Posts: 1
Registered: ‎03-19-2014

Re: Cannot communicate with the printer.

[ Edited ]

Thank you Ramona AND THANK YOU "SP_prt" !!

 

I've had this problem for months now and the error keeps coming up on my desktop and my laptops using the wireless router.  I had followed Ramona's instructions and once into Printer Properties, via the the Control Panel, found that the "Enable Bi-Directional Support" option had already been checked - yet the problem wouldn't go away.

Once I followed the further suggestion from SP_prt, I found that the checkbox was clear - after going through the GENERAL tab and selecting "Change Properties".

P.S. This clears up yet another problem I experienced once upgrading to Windows 8.1 using a Windows 7 desktop.

 

 

Please use plain text.
New Contributor
jecasogo
Posts: 2
Registered: ‎05-14-2014

Re: Cannot communicate with the printer.

[ Edited ]

I had to follow other steps but with the steps you provided anyone should be able to figure it out. Thank you so much as your post was extremely helpful. Thanks Ramona!

Please use plain text.